hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Vigeant <mark.vige...@riskmetrics.com>
Subject RE: Web Interface Not Working
Date Wed, 02 Dec 2009 17:26:50 GMT
Steve,

I apologize in advance for being a total n00b right here, but which classpath are we talking
about? Should I be modifying the classpath in HADOOP-ENV or should I be modifying the java
classpath?

Thanks
-Mark

-----Original Message-----
From: Steve Loughran [mailto:stevel@apache.org]
Sent: Wednesday, December 02, 2009 5:21 AM
To: common-user@hadoop.apache.org
Subject: Re: Web Interface Not Working

Mark Vigeant wrote:
> Todd,
>
> I followed your suggestion, shut down everything, restarted it, and the UI is still not
there. Jps shows NN and JT working though.
>

Web UI is precompiled JSP on jetty; the rest of the system doesn't need
it, and if the JSP JARs aren't on the classpath, Jetty won't behave.
  * make sure that you have only one version of Jetty on your classpath
  * make sure you only have one set of JSP JARs on the CP
  * make sure the jetty jars are all consistent (not mixing versions)
  * check that the various servlets are live (the TT and DNs have them).
No servlets: jetty is down.

I think you can tell Jetty to log at more detail, worth doing if you are
trying to track down problems.

This email message and any attachments are for the sole use of the intended recipients and
may contain proprietary and/or confidential information which may be privileged or otherwise
protected from disclosure. Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not an intended recipient, please contact the sender by reply email and destroy
the original message and any copies of the message as well as any attachments to the original
message.

Mime
View raw message