hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohan Agarwal <mohan.agarwa...@gmail.com>
Subject Re: Problem while starting hadoop
Date Thu, 05 Nov 2009 08:06:50 GMT
Hi ,
    I have forget to  mention that , I have installed *hadoop-0.20* in *stand
alone mode *on my system.

Thanking You
Mohan Agarwal

On Thu, Nov 5, 2009 at 1:19 PM, Mohan Agarwal <mohan.agarwal25@gmail.com>wrote:

> Hi,
>     I have installed *hadoop-0.20* on my system. I am facing a problem
> while starting hadoop using *start-all.sh* command.
>     I am getting the following error :
>
> *localhost: starting secondarynamenode, logging to
> /usr/lib/hadoop/bin/../logs/hadoop-root-secondarynamenode-magarwal.in.connectivasystems.com.out
> *
> localhost: Exception in thread "main" java.lang.NullPointerException
> localhost:      at
> org.apache.hadoop.net.NetUtils.createSocketAddr(NetUtils.java:134)
> localhost:      at
> org.apache.hadoop.hdfs.server.namenode.NameNode.getAddress(NameNode.java:161)
> localhost:      at
> org.apache.hadoop.hdfs.server.namenode.NameNode.getAddress(NameNode.java:165)
> localhost:      at
> org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.initialize(SecondaryNameNode.java:131)
> localhost:      at
> org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.<init>(SecondaryNameNode.java:115)
> localhost:      at
> org.apache.hadoop.hdfs.server.namenode.SecondaryNameNode.main(SecondaryNameNode.java:476)
>
> Above error suggest that *Secondary Name Node* is not getting started.*Although other
things is working fine
> *, I am also using hive (with Derby Network Server as a Metadata Store ).
> From Hive CLI , hive query is getting executed.
>
> Please help me to solve this problem.
>
> Thanking You
> Mohan Agarwal
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message