hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zhengguo 'Mike' SUN <zhengguo...@yahoo.com>
Subject Re: Job.setJarByClass in Hadoop 0.20.1
Date Tue, 24 Nov 2009 05:09:42 GMT
Hi Todd,

The hadoop-0.20.1+133-examples.jar worked fine. I just tried an Apache release. I copied the
example source file of WordCount.java to my jar and submitted the job. It worked with Apache's
release, but failed with CloudEra's release. But my code failed for both of the versions.




________________________________
From: Todd Lipcon <todd@cloudera.com>
To: common-user@hadoop.apache.org
Sent: Mon, November 23, 2009 11:34:22 PM
Subject: Re: Job.setJarByClass in Hadoop 0.20.1

Hi Mike,

I haven't seen that problem. There is one patch in the Cloudera distribution
that does modify the behavior of that method, though. Would you mind trying
this on the stock Apache 0.20.1 release? I see no reason to believe this is
the issue, since hundreds of other people are using our distro without
issues, but it's worth checking out.

Is this happening with every jar? What platform are you running on?

Thanks,
-Todd

On Mon, Nov 23, 2009 at 8:28 PM, Zhengguo 'Mike' SUN
<zhengguosun@yahoo.com>wrote:

> Hi,
>
> After porting my code from Hadoop 0.17 to 0.20, I am starting to have
> problems setting my jar file. I used to be able to set jar file by using
> JobConf.setJar(). But now I am using Job.setJarByClass(). It looks to me
> that this method is not working. I kept getting ClassNotFoundException when
> submitting my job. I also added Job.getJar() after Job.setJarByClass, but it
> did return null somehow. By the way, I am using CloudEra's distribution of
> hadoop-0.20.1+133.
>
> Anyone has the same problem?
>
>
>
>



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message