hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Massie <m...@cloudera.com>
Subject Re: Ganglia
Date Mon, 23 Nov 2009 17:04:53 GMT
John-

I would recommend that you drop into irc channel #ganglia on freenode or
join the ganglia-general mailing list (http://ganglia.info/) and send this
question there.  This seems like a configuration/firewall issue.

-Matt



On Mon, Nov 23, 2009 at 12:41 AM, John Martyniak <
john@beforedawnsolutions.com> wrote:

> Hi,
>
> I have been trying to get Hadoop working with Ganglia, and am making some
> progress.
>
> I have upgraded to Hadoop 0.20.1, and that seems to make a big difference,
> I no longer get any errors related to Ganglia.
>
> But when I run gmetad --debug=5, I get the following:
> [root@monitor ganglia]# gmetad --debug=5
> Going to run as user nobody
> Sources are ...
> Source: [hadoop cluser, step 15] has 4 sources
>        10.1.1.128
>        10.1.1.129
>        10.1.1.130
>        10.1.1.131
> xml listening on port 8651
> interactive xml listening on port 8652
> cleanup thread has been started
> Data thread 3023616912 is monitoring [hadoop cluser] data source
>        10.1.1.128
>        10.1.1.129
>        10.1.1.130
>        10.1.1.131
> data_thread() got no answer from any [hadoop cluser] datasource
>
> If telnet from 10.1.1.128 to the ganglia machine, it returns an XML string,
> so it can connect.
>
> I guess my question is do I need to run gmond or gexec on each individual
> node?  Or should it just write to ganglia machine, once it is configured in
> the hadoop-metrics.properties?
>
> Thank you,
>
> -john
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message