hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Huy Phan <dac...@gmail.com>
Subject Re: Mount WebDav in Linux for HDFS-0.20.1
Date Tue, 27 Oct 2009 10:55:57 GMT
Hi Zhang,

Here is the patch for davfs2 to solve "server does not support WebDAV" 

diff --git a/src/webdav.c b/src/webdav.c
index 8ec7a2d..4bdaece 100644
--- a/src/webdav.c
+++ b/src/webdav.c
@@ -472,7 +472,7 @@ dav_init_connection(const char *path)
     if (!ret) {
         initialized = 1;
-        if (!caps.dav_class1 && !caps.dav_class2 &&  !ignore_dav_header)
+        if (!caps.dav_class1 && !ignore_dav_header) {
             if (have_terminal) {
                 error(EXIT_FAILURE, 0,
                       _("mounting failed; the server does not support 

davfs2 and webdav is not a good mix actually, I had tried to mix them 
together and the performance were really bad. With the load test of 10 
requests/s, load average on my namenode were always > 15 and it took me 
about 5 mins for `ls` the root directory of HDFS during the test.

Since you're using Hadoop 0.20.1, it's better to use fusedfs library 
provided in Hadoop package. You have to do some tricks to compile 
fusedfs with Hadoop, otherwise it would take you a lot of time for 
compiling redundant things.

Huy Phan

Zhang Bingjun (Eddy) wrote:
> Dear Huy Phan and others,
> Thanks a lot for your efforts in customizing the WebDav server 
> <http://github.com/huyphan/HDFS-over-Webdav> and make it work for 
> Hadoop-0.20.1. 
> After setting up the WebDav server, I could access it using Cadaver 
> client in Ubuntu without using any username password. Operations like 
> deleting files, etc, were working. The command is: *cadaver 
> http://server:9800*
> However, when I was trying to mount the WebDav server using davfs2 in 
> Ubuntu, I always get the following error: 
> "mount.davfs: mounting failed; the server does not support WebDAV".
> I was promoted to input username and password like below: 
> hadoop@hdfs2:/mnt$ sudo mount.davfs 
> hdfs-webdav/
> Please enter the username to authenticate with server
> or hit enter for none.
> Username: hadoop
> Please enter the password to authenticate user hadoop with server
> or hit enter for none.
> Password:
> mount.davfs: mounting failed; the server does not support WebDAV
> Even though I have tried all possible usernames and passwords either 
> from the WebDAV accounts.properties file or from the Ubuntu system of 
> the WebDAV server, I still got this error message. 
> Could you and anyone give me some hints on this problem? How could I 
> solve it? Very much appreciate your help!
> Best regards,
> Zhang Bingjun (Eddy)
> E-mail: eddymier@gmail.com <mailto:eddymier@gmail.com>, 
> bingjun@nus.edu.sg <mailto:bingjun@nus.edu.sg>, 
> bingjun@comp.nus.edu.sg <mailto:bingjun@comp.nus.edu.sg>
> Tel No: +65-96188110 (M)

View raw message