hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Massie <m...@cloudera.com>
Subject Re: Using Ganglia with hadoop 0.19.0 on Amazon EC2
Date Wed, 09 Sep 2009 04:21:45 GMT
Ganglia doesn't need to be patched to work.  The patches are for Hadoop if
you are running ganglia 3.1.x (because of a breaking change in the ganglia
message format from 3.0.x to 3.1.x).

Since you are running fedora, you should be able to bring ganglia up by
using the ganglia RPMs which are available in the fedora repo.

Try the following commands on each node in the cluster you want to monitor

# yum install ganglia-gmond
# service gmond start

You will need to open TCP/UDP port 8649 as well to allow ganglia
communication (see your iptables configuration).  You can verify that gmond
is working by connecting to TCP port 8649

$ telnet localhost 8649

You should see an XML description of the state of the cluster/node.  Let me
know when you are this far in the installation and I'll help you through the
next steps.

-Matt



On Tue, Sep 8, 2009 at 7:49 PM, Samprita Hegde <sampritavh@gmail.com> wrote:

> The ami-id I am using is ami-fa6a8e93. It is a Fedora distribution for
> i-386
> .
> To be precise this is taken from the console output :
>
> Linux version 2.6.21.7-2.fc8xen (mockbuild@xenbuilder1.fedora.redhat.com)
> (gcc version 4.1.2 20070925 (Red Hat 4.1.2-33))
>
> I was looking into the Ganglia documentation in Hadoop wiki. It says we
> need
> to install a patch inorder to get it working. I am not sure if this ami has
> all the patched installed for ganglia.
>
> Thanks!
> Samprita
>
>
> On Tue, Sep 8, 2009 at 10:22 PM, Matt Massie <matt@cloudera.com> wrote:
>
> > I should be able to help you out.
> >
> > What AMI are you using?  What linux distribution?
> >
> > -Matt
> >
> > On Tue, Sep 8, 2009 at 6:21 PM, Samprita Hegde <sampritavh@gmail.com>
> > wrote:
> >
> > > Hello All,
> > >    I am trying to study the performance of ec2 cluster when it is
> running
> > > hadoop. But I am not able get ganglia up and running. Can someone
> please
> > > guide me as how to use/configure Ganglia to be able to run with hadoop
> .
> > I
> > > am using an public ec2 image that has hadoop-0.19.0. I have used the
> > > ganglia
> > > configuration that comes with the hadoop-ec2 scripts in the
> > hadoop-package.
> > >
> > >
> > > The ganglia version  that is running is ganglia 3.0.5.
> > >
> > > Thanks and Regards,
> > > Samprita
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message