hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tim robertson <timrobertson...@gmail.com>
Subject Re: Help with Hadoop/Hbase on s3
Date Fri, 07 Aug 2009 15:02:36 GMT
Do you need to add the Amazon S3 toolkit on the HBase classpath
directly to use S3 as a store?
http://developer.amazonwebservices.com/connect/entry.jspa?externalID=617&categoryID=47

I'm guessing based on the "java.lang.NoClassDefFoundError:
org/jets3t/service/S3ServiceException"

Cheers

Tim


On Fri, Aug 7, 2009 at 4:50 PM, Ananth T.
Sarathy<ananth.t.sarathy@gmail.com> wrote:
> I can't seem to get Hbase to run using the hadoop i have connected to my s3
> bucket
>
> Running
> Hbase 0.19.2
> Hadoop  0.19.2
>
> Hadoop-site.xml
>  < configuration>
>
> <property>
>  <name>fs.default.name</name>
>  <value>s3://hbase</value>
> </property>
>
> <property>
>  <name>fs.s3.awsAccessKeyId</name>
>  <value>ID</value>
> </property>
>
> <property>
>  <name>fs.s3.awsSecretAccessKey</name>
>  <value>SECRET</value>
> </property>
> </configuration>
>
> and it seems to start up no problem
>
> my hbase-site.xml
>
> <configuration>
>    <property>
>  <name>hbase.master</name>
>     <value>174.129.15.236:60000</value>
>     <description>The host and port that the HBase master runs at.
>     A value of 'local' runs the master and a regionserver in
>     a single process.
>     </description>
>   </property>
>
>  <property>
>    <name>hbase.rootdir</name>
>    <value>s3://hbase</value>
>    <description>The directory shared by region servers.
>    </description>
>  </property>
>
> </configuration>
>
>
> keeps giving me
>
> ]
> 2009-08-06 17:20:44,526 ERROR org.apache.hadoop.hbase.master.HMaster: Can
> not start master
> java.lang.NoClassDefFoundError: org/jets3t/service/S3ServiceException
>        at
> org.apache.hadoop.fs.s3.S3FileSystem.createDefaultStore(S3FileSystem.java:84)
>        at
> org.apache.hadoop.fs.s3.S3FileSystem.initialize(S3FileSystem.java:74)
>        at
> org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:1367)
>        at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:56)
>        at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:1379)
>        at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:215)
>        at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:120)
>        at org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:186)
>        at org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:156)
>        at
> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:96)
>        at
> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:78)
>        at org.apache.hadoop.hbase.master.HMaster.doMain(HMaster.java:1013)
>        at org.apache.hadoop.hbase.master.HMaster.main(HMaster.java:1057)
> Caused by: java.lang.ClassNotFoundException:
> org.jets3t.service.S3ServiceException
>        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
>        at java.security.AccessController.doPrivileged(Native Method)
>        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
>        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
>        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
>        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
>
>
> what am i doing wrong here?
>
> Ananth T Sarathy
>

Mime
View raw message