hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jason hadoop <jason.had...@gmail.com>
Subject Re: Datanode Cannot Connect To The Server
Date Fri, 17 Jul 2009 05:55:12 GMT
If your namenode is not binding to the ethernet port address, but only to
the localhost, your datanode will never be able to connect to it.

I vaguely remember that if the hostname of the node is found on the
localhost line in /etc/hosts, that this may happen.

On Thu, Jul 16, 2009 at 1:54 PM, Boyu Zhang <boyuzhang35@gmail.com> wrote:

> Thank you for your suggestion.
>
> I have done that plenty of times, and every time I delete the pids and the
> files /tmp/hadoop-name that namenode formate genrated. But I got the same
> error over and over.
>
>
> I found out that after I start-dfs.sh, I check the netstat -pnl(from the
> master),  there is a process listening on port 9000 with local address
> 127.0.0.2. But in the log file of the failed data node , it kept trying to
> connect to IP:9000 where IP is the actual IP of the master machine. And I
> tried to use IP address in stead of machine name, still not work. I am
> still
> trying to figure out why. It seems that not lots of people are having this
> problem, but I keep getting this error.
>
>
> Thanks a lot!
>
>
> On Thu, Jul 16, 2009 at 11:15 AM, zhang jianfeng <zjffdu@gmail.com> wrote:
>
> > It seems that your datanode is dead. My suggestion is that you can
> reformat
> > the namenode, and restart the cluster.
> >
>



-- 
Pro Hadoop, a book to guide you from beginner to hadoop mastery,
http://www.amazon.com/dp/1430219424?tag=jewlerymall
www.prohadoopbook.com a community for Hadoop Professionals

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message