hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyu Zhang" <boyuzhan...@gmail.com>
Subject RE: DataNode Cannot Start Incompatible namespaceIDs
Date Wed, 24 Jun 2009 20:19:31 GMT
Hi everyone,

Me again. The problem has been solved, I clean the stuff in /tmp and
everything works. Thanks.


-----Original Message-----
From: Boyu Zhang [mailto:bzhang@cs.utsa.edu] 
Sent: Wednesday, June 24, 2009 3:54 PM
To: core-user@hadoop.apache.org
Subject: DataNode Cannot Start Incompatible namespaceIDs

Hi everyone,


I am new to Hadoop. When I run start-all.sh in pseudo distributed model, I
got this 


ERROE: org.apache.hadoop.dfs.DataNode: java.io.IOException: Inconpatible
namespaceIDs in /tmp/hadoop-zhang/dfs/data: namenode
namespceID=13510389749;datanode namespaceID = 222833940.


So I cannot start the datanode. I am sure it is something stupid I did or
did not do, I just can't figure it out. I really appreciate it if somebody
could help me out. Thanks a lot.




Boyu Zhang


View raw message