hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Foss User <foss...@gmail.com>
Subject Re: Folders and files still present after format
Date Wed, 06 May 2009 19:26:10 GMT
On Thu, May 7, 2009 at 12:44 AM, Todd Lipcon <todd@cloudera.com> wrote:
> On Wed, May 6, 2009 at 11:40 AM, Foss User <fossist@gmail.com> wrote:
>
>> Today I formatted the namenode while the namenode and jobtracker was
>> up. I found that I was still able to browse the file system using the
>> command: bin/hadoop dfs -lsr /
>>
>> Then, I stopped the namenode and jobtracker and did a format again. I
>> started the namenode and jobtracker. I could still browse the file
>> system. Is this an expected behavior or a problem?
>>
>> I was formatting using the command: bin/hadoop namenode -format
>>
>> I was running this command on the namenode machine.
>>
>
> Were you running the format command as the same user that runs the namenode?
> With a default configuration, the dfs.name.dir has the user name included in
> it, so running that command as your user account won't affect the cluster if
> the cluster namenode is running as a "hadoop" account, for example.
>
> -Todd
>

Yes, as far as I remember but I am not absolutely sure. From your
reply, I understand what I experienced (may be due to my fault) is not
an expected behavior. So, if I face the same error again I would like
to provide more information to this list. What are the logs that I
should be uploading here for analysis if I see this again?

Mime
View raw message