hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Usman Waheed" <usm...@opera.com>
Subject One of my data nodes is under used: Datanode 4
Date Sun, 26 Apr 2009 15:54:08 GMT
Hi,

One of my data nodes is practically under utilized in the cluster of 4  
datanodes and one namenode.
I executed the hadoop -setrep -w 2 changing it from rep factor 3 for all  
files in the HDFS.

All the nodes are balancer except one. Any clues? Shall i run hadoop  
balancer after the rep factor is reset.

Thanks,
Usman


-------------------------------------------------
Datanodes available: 4

Name: 1
State          : In Service
Total raw bytes: 293778976768 (273.6 GB)
Remaining raw bytes: 217963111201(202.99 GB)
Used raw bytes: 52500185088 (48.89 GB)
% used: 17.87%
Last contact: Sun Apr 26 15:49:17 UTC 2009


Name: 2
State          : In Service
Total raw bytes: 293778976768 (273.6 GB)
Remaining raw bytes: 227810456463(212.17 GB)
Used raw bytes: 44199026688 (41.16 GB)
% used: 15.04%
Last contact: Sun Apr 26 15:49:19 UTC 2009


Name: 3
State          : In Service
Total raw bytes: 293778976768 (273.6 GB)
Remaining raw bytes: 207735568331(193.47 GB)
Used raw bytes: 63878131712 (59.49 GB)
% used: 21.74%
Last contact: Sun Apr 26 15:49:19 UTC 2009


Name: 4
State          : In Service
Total raw bytes: 293778976768 (273.6 GB)
Remaining raw bytes: 270775018072(252.18 GB)
Used raw bytes: 1916928 (1.83 MB)
% used: 0%
Last contact: Sun Apr 26 15:49:17 UTC 2009


-- 
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

Mime
View raw message