hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cam Macdonell <...@cs.ualberta.ca>
Subject Error reading task output
Date Wed, 15 Apr 2009 23:02:25 GMT

Hi,

I'm getting the following warning when running the simple wordcount and 
grep examples.

09/04/15 16:54:16 INFO mapred.JobClient: Task Id : 
attempt_200904151649_0001_m_000019_0, Status : FAILED
Too many fetch-failures
09/04/15 16:54:16 WARN mapred.JobClient: Error reading task 
outputhttp://localhost.localdomain:50060/tasklog?plaintext=true&taskid=attempt_200904151649_0001_m_000019_0&filter=stdout
09/04/15 16:54:16 WARN mapred.JobClient: Error reading task 
outputhttp://localhost.localdomain:50060/tasklog?plaintext=true&taskid=attempt_200904151649_0001_m_000019_0&filter=stderr

The only advice I could find from other posts with similar errors is to 
setup /etc/hosts with all slaves and the host IPs.  I did this, but I 
still get the warning above.  The output seems to come out alright 
however (I guess that's why it is a warning).

I tried running a wget on the http:// address in the warning message and 
I get the following back

2009-04-15 16:53:46 ERROR 400: Argument taskid is required.

So perhaps the wrong task ID is being passed to the http request.  Any 
ideas on what can get rid of these warnings?

Thanks,
Cam

Mime
View raw message