hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patterson, Josh" <jpatters...@tva.gov>
Subject RE: Issues installing FUSE_DFS
Date Tue, 03 Mar 2009 20:10:07 GMT
Brian,
Do you know of anyone using Samba to access the FUSE-DFS mount point via
windows? We have FUSE-DFS working, but read/write doesn't work via
Samba.

Josh Patterson 

-----Original Message-----
From: Brian Bockelman [mailto:bbockelm@cse.unl.edu] 
Sent: Tuesday, March 03, 2009 11:26 AM
To: core-user@hadoop.apache.org
Subject: Re: Issues installing FUSE_DFS


On Mar 3, 2009, at 10:01 AM, Patterson, Josh wrote:

> Hey Brian,
> I'm working with Matthew on our hdfs install, and he's doing the  
> server
> admin on this project; We just tried the settings you suggested, and  
> we
> got the following error:
>
>
>
>
> [root@socdvmhdfs1 ~]# fuse_dfs -oserver=socdvmhdfs1 -oport=9000 /hdfs
> -oallow_ot
> her -ordbuffer=131072
> fuse-dfs didn't recognize /hdfs,-2
> fuse-dfs ignoring option allow_other
> [root@socdvmhdfs1 ~]# df -h
> Filesystem            Size  Used Avail Use% Mounted on
> /dev/mapper/VolGroup00-LogVol00
>                      5.8G  3.7G  1.9G  67% /
> /dev/sda1              99M   18M   77M  19% /boot
> tmpfs                 506M     0  506M   0% /dev/shm
> df: `/hdfs': Input/output error
>

So, you have a successful mount, but for some reason it's not talking  
to Hadoop.

Try adding the "-d" flag; this will mount FUSE in debug mode, and any  
Hadoop errors (or whatever is causing the Input/output error) will be  
printed to the terminal.

Brian

>
>
> We are using Redhat EL5 and hadoop 0.19; We did have some trouble
> compiling FUSE-DFS but got through the compilation errors. Any  
> advice on
> what to try next?
>
> Josh Patterson
> TVA
>
>
>
> -----Original Message-----
> From: Brian Bockelman [mailto:bbockelm@cse.unl.edu]
> Sent: Monday, March 02, 2009 5:30 PM
> To: core-user@hadoop.apache.org
> Subject: Re: Issues installing FUSE_DFS
>
> Hey Matthew,
>
> We use the following command on 0.19.0:
>
> fuse_dfs -oserver=hadoop-name -oport=9000 /mnt/hadoop -oallow_other -
> ordbufffer=131072
>
> Brian
>
> On Mar 2, 2009, at 4:12 PM, Hyatt, Matthew G wrote:
>
>> When we try to mount the dfs from fuse we are getting the following
>> errors. Has anyone seen this issues in the past? This is on version
>> 0.19.0
>>
>>
>> [root@socdvmhdfs1]# fuse_dfs dfs://socdvmhdfs1:9000 /hdfs
>> port=9000,server=socdvmhdfs1
>> fuse-dfs didn't recognize /hdfs,-2
>>
>> [root@socdvmhdfs1]# df -h
>> Filesystem            Size  Used Avail Use% Mounted on
>> /dev/mapper/VolGroup00-LogVol00
>>                     5.8G  3.7G  1.9G  67% /
>> /dev/sda1              99M   18M   77M  19% /boot
>> tmpfs                 506M     0  506M   0% /dev/shm
>> df: `/hdfs': Input/output error
>>
>>
>> Matthew G. Hyatt
>> Tennessee Valley Authority
>> TRO Configuration Management
>> System Admin UNIX/NT
>> phone: 423-751-4189
>> e-mail: mghyatt@tva.gov
>>


Mime
View raw message