hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen, Jeffrey" <jal...@ll.mit.edu>
Subject Multiple user permissions
Date Thu, 18 Dec 2008 15:31:42 GMT
Greetings

I successfully installed a cloud w/ 4 computers logged in with my own account (jallen).  I
want to expose the cloud to other users using a generic account.  So, after installing the
SW and formatting the file system I went through and performed a chmod on the installation
directory and the root of the hadoop file system so everyone would have read and write access.

However when I run a command like: "bin/hadoop fs -mkdir input" from the generic account I
get:
mkdir: org.apache.hadoop.security.AccessControlException: Permission denied: user=hadoop,
access=WRITE, inode="user":jallen:supergroup:rwxr-xr-x

I was wondering if the problem may have been created when I changed the hadoop.tmp.dir attribute
to be just /tmp/hadoop and not based on the user's name as is the default /tmp/hadoop-${user.name}
but after removing that attribute in hadoop-site.xml, restarting and reformatting, I still
get the same error.

Any thoughts of what's getting accessed or how to solve this?

Jeff





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message