hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arijit Mukherjee" <armukher...@connectivasystems.com>
Subject Hadoop eclipse plugin
Date Tue, 26 Aug 2008 05:06:26 GMT
Hi All

Have anyone tried the Eclipse plugin for Hadoop? I've been able to add
the plugin to Eclipse, however, I can see couple of problems there -
probably I did something wrong.

(1) When I try to add a new hadoop location, the plugin is never able to
find it. I'm not sure which ports to put inside the config box - I've
tried several of them including the namenode, jobtracker etc - but it
always fails to add the hadoop server. Following is the output of
netstat which I used to check the ports -

strawberry:/home/hadoop> netstat -plten | grep java
tcp        0      0 :::8354                     :::*
LISTEN      507        21343      8878/java           
tcp        0      0 :::19300                    :::*
LISTEN      507        21418      8954/java           
tcp        0      0 ::ffff:127.0.0.1:54310      :::*
LISTEN      507        20857      8564/java           
tcp        0      0 ::ffff:127.0.0.1:54311      :::*
LISTEN      507        21421      8954/java           
tcp        0      0 :::50090                    :::*
LISTEN      507        21369      8878/java           
tcp        0      0 :::50060                    :::*
LISTEN      507        21712      9118/java           
tcp        0      0 :::50030                    :::*
LISTEN      507        21471      8954/java           
tcp        0      0 ::ffff:127.0.0.1:53522      :::*
LISTEN      507        21717      9118/java           
tcp        0      0 :::5205                     :::*
LISTEN      507        20854      8564/java           
tcp        0      0 :::50070                    :::*
LISTEN      507        21005      8564/java

And the processes are running as -

strawberry:/home/hadoop> jps
8878 SecondaryNameNode
8564 NameNode
8954 JobTracker
9216 Jps
8079 
9118 TaskTracker

(2) If I create a MapReduce project and add the Mapper and Reduce
classes, the signature of the generated classes are different from
what's there in the Hadoop APIs - as a result of which, there's a
compilation error.

Please can anyone point me to the right directions? I've also raised
these questions to the plugin forum, but thought someone here may be
able to help as well.

Regards
Arijit

Dr. Arijit Mukherjee
Principal Member of Technical Staff, Level-II
Connectiva Systems (I) Pvt. Ltd.
J-2, Block GP, Sector V, Salt Lake
Kolkata 700 091, India
Phone: +91 (0)33 23577531/32 x 107
http://www.connectivasystems.com


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message