hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lincoln Ritter" <linc...@lincolnritter.com>
Subject Re: Bean Scripting Framework?
Date Fri, 25 Jul 2008 17:22:46 GMT
I was using BSF to avoid java 6 issues.  However I'm having similar
issues using both systems.  Basically, I can't load the scripting
engine from within hadoop.  I have successfully compiled and run some
stand-alone test examples but am having trouble getting anything to
work from hadoop.  One confounding factor is that my development
machine is OS X 10.5 with the stock 1.5 JDK.  On the surface this
doesn't seem to be a problem given the success I've had at creating
small stand-alone tests...  I run the stand-alone stuff with exactly
the same classpath and environment so it seems that something weird is
going on.  Additionally, as a sanity check, I've tried loading the
javascript engine and that does work from within hadoop.

All the JSR jars are on the classpath and I'm kinking off the hadoop
process using the -Djruby.home=... option.  Did you have to do
anything special here?



On Thu, Jul 24, 2008 at 7:00 PM, James Moore <jamesthepiper@gmail.com> wrote:
> On Thu, Jul 24, 2008 at 3:51 PM, Lincoln Ritter
> <lincoln@lincolnritter.com> wrote:
>> Well that sounds awesome!  It would be simply splendid to see what
>> you've got if you're willing to share.
> I'll be happy to share, but it's pretty much in pieces, not ready for
> release.  I'll put it out with whatever license Hadoop itself uses
> (presumably Apache).
>> Are you going the 'direct' embedding route or using a scripting frame
>> work (BSF or javax.script)?
> JSR233 is the way to go according to the JRuby guys at RailsConf last
> month.  It's pretty straightforward - see
> http://wiki.jruby.org/wiki/Java_Integration#Java_6_.28using_JSR_223:_Scripting.29
> --
> James Moore | james@restphone.com
> Ruby and Ruby on Rails consulting
> blog.restphone.com

View raw message