hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lev Givon <...@columbia.edu>
Subject Re: login error while running hadoop on MacOSX 10.5.*
Date Thu, 26 Jun 2008 15:17:32 GMT
Received from Stefan Groschupf on Mon, Jun 23, 2008 at 05:47:46PM EDT:
> Sorry I'm not a unix expert, however the problem is clearly related
> to whoami since this throws an error.  I run hadoop in all kind of
> configuration super smooth on my os x boxes.  Maybe rename or move
> /sw/whoami for a test.  

It seems that the problem involves the path of the Fink-installed
binary rather than its actual contents; consider the following
evidence.

Since /sw/bin/whoami is actually a link to the binary
/sw/lib/coreutils/bin/whoami, I tried replacing /sw/bin/whoami with a
bash script that invokes /usr/bin/whoami instead and saves the results
of running /usr/bin/id in a file. Not only did the same error I
mentioned earlier occur when I attempted to run a hadoop job, but the
saved output of /usr/bin/id contained

uid=501 gid=501
groups=501,98(_lpadmin),81(_appserveradm),79(_appserverusr),80(admin),101

rather than what I obtain when I run /usr/bin/id from the terminal:

uid=501(lev) gid=501(lev)
groups=501(lev),98(_lpadmin),81(_appserveradm),79(_appserverusr),80(admin),101(com.apple.access_ssh)

This indicates that the getuid() system call performed by id (and
whoami) can't obtain my username mapping from MacOSX's directory
service (the other user names such as _lpadmin are stored in
/etc/passwd and hence do not require the directory service to be
successfully mapped). The implication is that Java is preventing the
system call from succeeding when it is invoked by an executable in
/sw/bin (regardless of what that executable actually does). I have no
idea whether this apparent security constraint can be reconfigured,
though.

> Also make sure you restart the os x console since changes in
> .bash_profile are only picked up if you "relogin" into the command
> line.  Sorry that is all I know and could guess.. :(

Thanks all the same. 

							L.G.

Mime
View raw message