hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From novice user <pallavip...@gmail.com>
Subject java.io.IOException: All datanodes are bad. Aborting...
Date Thu, 19 Jun 2008 11:32:00 GMT

Hi Every one,
 I am running a simple map-red application similar to k-means. But, when I
ran it in on single machine, it went fine with out any issues. But, when I
ran the same on a hadoop cluster of 9 machines. It fails saying 
java.io.IOException: All datanodes are bad. Aborting...

Here is more explanation about the problem:
I tried to upgrade my hadoop cluster to hadoop-17. During this process, I
made a mistake of not installing hadoop on all machines. So, the upgrade
failed. Nor I was able to roll back.  So, I re-formatted the name node
afresh. and then hadoop installation was successful.

Later, when I ran my map-reduce job, it ran successfully,but  the same job
with zero reduce tasks is failing with the error as:
java.io.IOException: All datanodes  are bad. Aborting...

When I looked into the data nodes, I figured out that file system is 100%
full with different directories of name "subdir" in
hadoop-username/dfs/data/current directory. I am wondering where I went
Can some one please help me on this?

The same job went fine on a single machine with same amount of input data.


View this message in context: http://www.nabble.com/java.io.IOException%3A-All-datanodes-are-bad.-Aborting...-tp18006296p18006296.html
Sent from the Hadoop core-user mailing list archive at Nabble.com.

View raw message