hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca <raskolnikof...@yahoo.it>
Subject [HOD] Example script
Date Wed, 05 Mar 2008 12:33:21 GMT
Hello everyone,
	in http://hadoop.apache.org/core/docs/r0.16.0/hod.html there is no
mention of scripting abilities of HOD, but with version 0.3 I was used
to do something like:

hod -m N -a "run jar foo.jar jar-parameters"

now I see that in 0.4.0 -a refers to logs-collection and option -z
refers to script.

I wrote a two-lines bash script with this code in it:

hadoop --config /home/luca/hod-test jar
/mnt/scratch/hadoop/hadoop-0.16.0-examples.jar wordcount
file:///mnt/scratch/hadoop/test/part-00000 test.hodscript.out

which is launched right after the allocation, but gets stuck on some

08/03/05 12:43:14 INFO ipc.Client: Retrying connect to server:
svr3.com/ Already tried 10 time(s).
java.net.ConnectException: Connection refused

The script was launched with command:

hod -m 3 -z test-script.sh

Noticeably, if I from the shell I run manually:
$ hod -o "allocate . 4"
$ hadoop --config . jar /mnt/scratch/hadoop/hadoop-0.16.0-examples.jar
wordcount file:///mnt/scratch/hadoop/test/part-00000 test.hodscript.out
$ hod -o "deallocate ."

everything works well, so I'm pretty sure I'm doing a mistake with the
script, but I didn't find any example to work on. I'm not sure what's
changing in regard to ports among the two invocations.


View raw message