hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cass Costello" <cas...@gmail.com>
Subject Re: Confusing connection issue with client
Date Sun, 03 Feb 2008 17:38:24 GMT
Thanks for the quick reply, Jean-Daniel.
I'm running the test remotely from the cluster.  I used the 0.15.3 release
for all the machines in the cluster and but built the local code from
branch-0.15.  To be safe, I just reran the test using jars from the
0.15.3download but received the same error.


On Feb 3, 2008 7:04 AM, Jean-Daniel Cryans <jdcryans@gmail.com> wrote:

> Hi,
>
> I guess you're using the SVN version. Are you running your test on the
> master node or remotely?
>
> jdcryans
>
> 2008/2/3, Cass Costello <casspc@gmail.com>:
> >
> > Hey all,
> > I'm just starting with both Hadoop and HBase.  I've created a 3-node
> > cluster
> > - 1 master and 2 slaves.  I've had some fun in the shell, where
> everything
> > works as expected, and look forward to wrapping my head around the java
> > client interface.  Using the wiki FAQ as a guide, I wrote my first unit
> > test, but it's throwing an exception I can't explain:
> >
> > 08/02/03 00:12:46 INFO hbase.HConnectionManager$TableServers: Attempt 0
> of
> > 5
> > failed with <org.apache.hadoop.ipc.RemoteException: java.io.IOException:
> > Unknown protocol to name node: org.apache.hadoop.hbase.HMasterInterface
> >
> > at org.apache.hadoop.dfs.NameNode.getProtocolVersion(NameNode.java:79)
> >
> > at jrockit.reflect.VirtualNativeMethodInvoker.invoke(Ljava.lang.Object;[
> > Ljava.lang.Object;)Ljava.lang.Object;(Unknown Source)
> >
> > at java.lang.reflect.Method.invoke(Ljava.lang.Object;[Ljava.lang.Object
> > ;I)Ljava.lang.Object;(Unknown
> > Source)
> >
> > at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:379)
> >
> > at org.apache.hadoop.ipc.Server$Handler.run(Server.java:596)
> >
> >
> > My hbase-site.xml and unit test source are below.  I haven't altered
> > hbase-default.  I feel like I must be missing something obvious. Any
> > ideas?
> >
> >
> >
> > public void testJustGettingStarted() throws Exception {
> >
> > Configuration conf = new HBaseConfiguration();
> >
> > HBaseAdmin admin = new HBaseAdmin(conf);
> >
> > HTableDescriptor[] tables = admin.listTables();
> >
> > for ( HTableDescriptor table : tables ) {
> >
> > LOG.info( table.getName() );
> >
> > }
> >
> > HTable newA = new HTable(conf, new Text("test") );
> >
> > Text row = new Text("testRow");
> >
> > // Now fetch the content just added
> >
> > byte data[] = newA.get(row, new Text("test:test") );
> >
> > LOG.info( data );
> >
> > }
> >
> >
> >
> > <?xml version="1.0"?>
> >
> > <configuration>
> >
> >   <property>
> >
> >     <name>hbase.master</name>
> >
> >     <value>blc-1300-07.dev:51515</value>
> >
> >     <description>The host and port that the Hbase master runs at.
> >
> >     </description>
> >
> >   </property>
> >
> > </configuration>
> >
>



-- 
Lego timeline:
http://cache.gizmodo.com/assets/resources/2008/01/lego-brick4-timeline.jpg

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message