hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ma qiang" <maqiang1...@gmail.com>
Subject Re: the "127.0.1.1:60020" in HBase
Date Fri, 18 Jan 2008 08:27:06 GMT
Dear Mafish liu:
         I haven't changed anything in my hbase-default.xml . I only
changed hbase-site.xml .
         I don't know what happened in my hadoop. I deleted all the
hadoop to reinstall the whole hadoop then the error  disappear. I
don't know what's wrong .
         Thanks very much !   Thank you for your responses !

         Best wishes !

--
Qiang Ma
Department of Computer Science and Engineering
Fudan University
Shanghai, P. R. China
EMail: maqiang1984@gmail.com


On Jan 18, 2008 4:17 PM, Mafish Liu <mafish@gmail.com> wrote:
> Port 60020 is default hbase.regionserver port in my hbase-defaut.xml.
>
>   <property>
>     <name>hbase.regionserver</name>
>     <value>0.0.0.0:60020</value>
>     <description>The host and port a HBase region server runs at.
>     </description>
>   </property>
>
> how about yours?
>
>
> On Jan 18, 2008 4:04 PM, Mafish Liu <mafish@gmail.com> wrote:
>
> > Hi, ma qiang:
> >     It seems that you had modified hadoop-site.xml to assign new ip/port.
> > Try to do following (I'm not quite sure it will work):
> > 1. Stop your hadoop and hbase.
> > 2. In your HADOOP_HOME, run "ant jar"
> > 3. Restart hadoop and hbase.
> >
> >
> > On Jan 18, 2008 3:28 PM, ma qiang <maqiang1984@gmail.com> wrote:
> >
> > > Yes, I'm sure I have my hadoop run ar first, and I can run my another
> > > test in my hadoop .
> > >
> > >
> > > On Jan 18, 2008 3:20 PM, Mafish Liu <mafish@gmail.com > wrote:
> > > > Are you sure that you hava had your hadoop run before you run your
> > > test?
> > > > 127.0.1.1:60020 is the namenode's ip:port, hbase is based on hadoop,
> > > it need
> > > > to
> > > > connent to hadoop.
> > > >
> > > >
> > > > On Jan 18, 2008 12:16 PM, ma qiang <maqiang1984@gmail.com> wrote:
> > > >
> > > > > Dear colleagues;
> > > > >       I run the code as described below:
> > > > > HBaseConfiguration conf = new HBaseConfiguration();
> > > > > HBaseAdmin admin = new HBaseAdmin(conf);
> > > > > HTableDescriptor[] tables = admin.listTables();
> > > > >
> > > > >
> > > > > I see errors :
> > > > > 08/01/18 12:11:56 INFO ipc.Client: Retrying connect to server:
> > > > > /127.0.1.1:60020. Already tried 1 time(s).
> > > > > 08/01/18 12:11:57 INFO ipc.Client: Retrying connect to server:
> > > > > /127.0.1.1:60020. Already tried 2 time(s).
> > > > > 08/01/18 12:11:58 INFO ipc.Client: Retrying connect to server:
> > > > > /127.0.1.1:60020. Already tried 3 time(s).
> > > > > 08/01/18 12:11:59 INFO ipc.Client: Retrying connect to server:
> > > > > /127.0.1.1:60020. Already tried 4 time(s).
> > > > > 08/01/18 12:12:00 INFO ipc.Client: Retrying connect to server:
> > > > > /127.0.1.1:60020. Already tried 5 time(s).
> > > > > 08/01/18 12:12:01 INFO ipc.Client: Retrying connect to server:
> > > > > /127.0.1.1:60020. Already tried 6 time(s).
> > > > > 08/01/18 12:12:02 INFO ipc.Client: Retrying connect to server:
> > > > > /127.0.1.1:60020. Already tried 7 time(s).
> > > > >
> > > > > I don't know what is the 127.0.1.1:60020, and I don't find it in
my
> > > > > hbase-site.xml and hbase-default.xml,  Can you tell me what's this
> > > and
> > > > > how to solve it.
> > > > > Thanks very much!
> > > > > Best wishes.
> > > > >
> > > > > --
> > > > > Qiang Ma
> > > > > Department of Computer Science and Engineering
> > > > > Fudan University
> > > > > Shanghai, P. R. China
> > > > > EMail: maqiang1984@gmail.com
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > Mafish@gmail.com
> > > > Institute of Computing Technology, Chinese Academy of Sciences,
> > > Beijing.
> > > >
> > >
> >
> >
> >
> > --
> >
> > Mafish@gmail.com
> > Institute of Computing Technology, Chinese Academy of Sciences, Beijing.
> >
>
>
>
> --
>
> Mafish@gmail.com
> Institute of Computing Technology, Chinese Academy of Sciences, Beijing.
>

Mime
View raw message