hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Holger Stenzhorn <holger.stenzh...@gmail.com>
Subject Re: NoSuchElementException when creating a table
Date Fri, 02 Nov 2007 16:35:39 GMT
Hi,

remarks inline...

Cheers,
Holger

Michael Stack wrote:
> Holger Stenzhorn wrote:
>> Hi,
>>
>> It was (again) the mistake of the guy in front of the screen... Sorry!
>> I did not set the "hadoop.tmp.dir"  manually: So when I did set it, 
>> as done by you, it works.
>
> So, to be clear, if you'd followed the content of the 
> http://wiki.apache.org/lucene-hadoop/Hbase/10Minutes faithfully -- 3.1 
> says set the hadoop.tmp.dir -- do you think things would have just 
> worked? (We're trying to get our 'getting started' documentation in 
> order).
>
Yes. ...when you fully (!) follow the steps - including setting the 
haddop.tmp.dir - then it works fine.

>> BUT then again, the "hadoop-default.xml" contains for 
>> "hadoop.tmp.dir" the value "/tmp/hadoop-${user.name}".
>> ...and this works fine for (actual) Hadoop creating and using (in my 
>> case) the directory "c:\tmp\hadoop-holste".
>> Does HBase treat the path differently than Haddop?
>>
> Hadoop RunJar looks to contain the only use of hadoop.tmp.dir other 
> than test and contrib code.  It does the following: 'new File(new 
> Configuration().get("hadoop.tmp.dir"));' using java.io.File.  In 
> hbase, its all Path and hadoop FileSystem. So, yes, content of 
> hadoop.tmp.dir is treated differently.
Could that be changed? ...meaning, wouldn't it be sensible to change 
HBase (to use Path etc.) so it behaves like Hadoop?
>
> Did you just change the value of hadoop.tmp.dir from 
> /tmp/hadoop-${user.name} to /tmp/hadoop-holste on cygwin and it then 
> worked?
No. I changed it to changed the value "c:\tmp\hadoop-holste".
>
>
>> Also, I tried to do the very same (as described in my intitial mail) 
>> on Ubuntu also *without* specifying "hadoop.tmp.dir".
>> There it works wihtout problems...
>
> Yeah.  I know things work out-of-the-box on linux/macosx.  Jim has 
> been doing a bunch of work trying to get the same to happen on cygwin 
> (10Minutes has the latest fruit of his work).
>>
>> As requested by Michel Stack I also attach my log (turned to debug) 
>> when starting the server.
>
> Thanks for the log.  Comments interlaced.
>>
>> Cheers,
>> Holger
>>
>> 07/11/02 13:40:09 DEBUG conf.Configuration: java.io.IOException: 
>> config()
>>   at org.apache.hadoop.conf.Configuration.<init>(Configuration.java:144)
>>   at 
>> org.apache.hadoop.hbase.HBaseConfiguration.<init>(HBaseConfiguration.java:30)

>>
>>   at org.apache.hadoop.hbase.HMaster.doMain(HMaster.java:3043)
>>   at org.apache.hadoop.hbase.HMaster.main(HMaster.java:3097)

...

Mime
View raw message