hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Reed <br...@yahoo-inc.com>
Subject Re: Hadoop 0.5.0 Issues
Date Thu, 17 Aug 2006 14:35:36 GMT
There was a protocol change in 0.5.0 are you sure you are using the 0.5.0 
libraries with your sample app?

ben

On Thursday 17 August 2006 05:55, Jagadeesh wrote:
> Hi All,
>
> I have been using Hadoop 0.4.0 for the past 1 month with 22 slaves and 1
> master node. So far there are no issues except for the log which I had
> already mentioned and I rectified it by configuring log4j. I am very
> impressed with this piece of software.
>
> However when I installed 0.5.0 on a test machine, I noticed some weird
> behaviors. I could start the server in stand-alone mode and the app works
> if I use the DFS Client to upload and download files. But it just hangs
> when I tried connecting from another box using a sample Java app I wrote.
> The sample app works in 0.4.0 without any issues. I thought there is
> something wrong with the way I have configured Hadoop and tried with
> different configurations. Then I understood that, downloading a file using
> sample app works in 0.5.0, but it's taking ages for downloading a file of
> size 1 KB and most of the time that too doesn't work.
>
> So I strongly feel the configurations are right as I was able to download
> the file even though it took some time. I verified log files and everything
> seems to be fine except for the below exception.
>
> 2006-08-16 12:35:07,214 WARN org.apache.hadoop.dfs.DataNode: DataXCeiver
> java.net.SocketException: Connection reset
>         at java.net.SocketInputStream.read(SocketInputStream.java:168)
>         at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)
>         at java.io.BufferedInputStream.read1(BufferedInputStream.java:256)
>         at java.io.BufferedInputStream.read(BufferedInputStream.java:313)
>         at java.io.DataInputStream.read(DataInputStream.java:134)
>         at
> org.apache.hadoop.dfs.DataNode$DataXceiver.writeBlock(DataNode.java:720)
>         at
> org.apache.hadoop.dfs.DataNode$DataXceiver.run(DataNode.java:507) at
> java.lang.Thread.run(Thread.java:595)
>
>
> I will appreciate any help or pointers to resolve this. I really want to
> use 0.5.0 but this error is holding me back.
>
> Thanks
> Jugs

Mime
View raw message