hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (Jira)" <j...@apache.org>
Subject [jira] [Work logged] (HADOOP-17282) libzstd-dev should be used instead of libzstd1-dev on Ubuntu 18.04 or higher
Date Fri, 25 Sep 2020 13:36:00 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-17282?focusedWorklogId=491020&page=com.atlassian.jira.plugin.system.issuetabpanels:worklog-tabpanel#worklog-491020
]

ASF GitHub Bot logged work on HADOOP-17282:
-------------------------------------------

                Author: ASF GitHub Bot
            Created on: 25/Sep/20 13:35
            Start Date: 25/Sep/20 13:35
    Worklog Time Spent: 10m 
      Work Description: tkuramoto33 opened a new pull request #2336:
URL: https://github.com/apache/hadoop/pull/2336


   libzstd1-dev is a transitional package on Ubuntu 18.04. It is better to use libzstd-dev
instead of libzstd1-dev in the Dockerfile (dev-support/docker/Dockerfile).
   
   I have tested this patch in a docker container, and the results are as follows:
   
   1. zstd version
   
   ```
   hadoop@ac937c1afb72:~/hadoop$ sudo apt search libzstd
   Sorting... Done
   Full Text Search... Done
   libzstd-dev/bionic-updates,bionic-security,now 1.3.3+dfsg-2ubuntu1.1 amd64 [installed]
     fast lossless compression algorithm -- development files
   libzstd1/bionic-updates,bionic-security,now 1.3.3+dfsg-2ubuntu1.1 amd64 [installed]
     fast lossless compression algorithm
   libzstd1-dev/bionic-updates,bionic-security 1.3.3+dfsg-2ubuntu1.1 amd64
     transitional package for libzstd-dev
   ```
   
   2. Is zstd enabled?
   
   The result of `cd hadoop-common-project/hadoop-common; mvn test -Dtest=TestZStandard*`
is shown below.
   
   ```
   [INFO] --- maven-surefire-plugin:3.0.0-M1:test (default-test) @ hadoop-common ---
   [INFO] 
   [INFO] -------------------------------------------------------
   [INFO]  T E S T S
   [INFO] -------------------------------------------------------
   [INFO] Running org.apache.hadoop.io.compress.zstd.TestZStandardCompressorDecompressor
   [INFO] Tests run: 19, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.467 s - in org.apache.hadoop.io.compress.zstd.TestZStandardCompressorDecompressor
   [INFO] 
   [INFO] Results:
   [INFO] 
   [INFO] Tests run: 19, Failures: 0, Errors: 0, Skipped: 0
   ```


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org


Issue Time Tracking
-------------------

    Worklog Id:     (was: 491020)
    Time Spent: 2h  (was: 1h 50m)

> libzstd-dev should be used instead of libzstd1-dev on Ubuntu 18.04 or higher
> ----------------------------------------------------------------------------
>
>                 Key: HADOOP-17282
>                 URL: https://issues.apache.org/jira/browse/HADOOP-17282
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Takeru Kuramoto
>            Assignee: Takeru Kuramoto
>            Priority: Minor
>              Labels: pull-request-available
>             Fix For: 3.4.0
>
>          Time Spent: 2h
>  Remaining Estimate: 0h
>
> libzstd1-dev is a transitional package on Ubuntu 18.04.
> It is better to use libzstd-dev instead of libzstd1-dev in the Dockerfile (dev-support/docker/Dockerfile).



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message