hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhishek Modi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-16093) Move DurationInfo from hadoop-aws to hadoop-common org.apache.fs.impl
Date Thu, 07 Feb 2019 17:35:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-16093?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16762896#comment-16762896
] 

Abhishek Modi commented on HADOOP-16093:
----------------------------------------

[~stevel@apache.org] Should we move it to hadoop-common-project? Somewhat like hadoop/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/OperationDuration.java

> Move DurationInfo from hadoop-aws to hadoop-common org.apache.fs.impl
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-16093
>                 URL: https://issues.apache.org/jira/browse/HADOOP-16093
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/s3, util
>            Reporter: Steve Loughran
>            Assignee: Abhishek Modi
>            Priority: Minor
>
> It'd be useful to have DurationInfo usable in other places (e.g. distcp, abfs, ...).
But as it is in hadoop-aws under {{org.apache.hadoop.fs.s3a.commit.DurationInfo
> org.apache.hadoop.fs.s3a.commit.DurationInfo}} we can't do that
> Move it.
> We'll have to rename the Duration class in the process, as java 8 time has a class of
that name too. Maybe "OperationDuration", with DurationInfo a subclass of that
> Probably need a test too, won't it?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message