hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-15617) Reduce node.js and npm package loading in the Dockerfile
Date Wed, 16 Jan 2019 12:35:00 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-15617?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steve Loughran updated HADOOP-15617:
------------------------------------
    Status: Patch Available  (was: Reopened)

This is aw's patch. There's a much bigger diff in trunk, but I'm avoiding that

> Reduce node.js and npm package loading in the Dockerfile
> --------------------------------------------------------
>
>                 Key: HADOOP-15617
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15617
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 2.9.3
>            Reporter: Allen Wittenauer
>            Priority: Major
>         Attachments: HADOOP-15617-branch-2-001.patch
>
>
> {code}
> RUN apt-get -y install nodejs && \
>     ln -s /usr/bin/nodejs /usr/bin/node && \
>     apt-get -y install npm && \
>     npm install npm@latest -g && \
>     npm install -g bower && \
>     npm install -g ember-cli
> {code}
> should get reduced to
> {code}
> RUN apt-get -y install nodejs && \
>     ln -s /usr/bin/nodejs /usr/bin/node && \
>     apt-get -y install npm && \
>     npm install npm@latest -g
> {code}
> The locally installed versions of bower and ember-cli aren't being used anymore.  Removing
these cuts the docker build time significantly.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message