hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira Ajisaka (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-15994) Upgrade Jackson2 to the latest version
Date Thu, 13 Dec 2018 03:24:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-15994?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16719708#comment-16719708
] 

Akira Ajisaka commented on HADOOP-15994:
----------------------------------------

Given Jackson is widely used in Apache Hadoop, I will run full unit tests.

> Upgrade Jackson2 to the latest version
> --------------------------------------
>
>                 Key: HADOOP-15994
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15994
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: security
>            Reporter: Akira Ajisaka
>            Assignee: lqjacklee
>            Priority: Major
>         Attachments: HADOOP-15994-001.patch, HADOOP-15994-002.patch, HADOOP-15994-003.patch
>
>
> Now Jackson 2.9.5 is used and it is vulnerable (CVE-2018-11307). Let's upgrade to 2.9.6
or upper.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message