hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohith Sharma K S (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-15884) Compilation fails for hadoop-yarn-server-timelineservice-hbase-client package
Date Mon, 29 Oct 2018 05:38:00 GMT
Rohith Sharma K S created HADOOP-15884:
------------------------------------------

             Summary: Compilation fails for hadoop-yarn-server-timelineservice-hbase-client
package
                 Key: HADOOP-15884
                 URL: https://issues.apache.org/jira/browse/HADOOP-15884
             Project: Hadoop Common
          Issue Type: Bug
            Reporter: Rohith Sharma K S


Dependency check for hbase-client package fails
{noformat}
[INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (depcheck) @ hadoop-yarn-server-timelineservice-hbase-client
---
[WARNING]
Dependency convergence error for org.eclipse.jetty:jetty-http:9.3.24.v20180605 paths to dependency
are:
+-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
  +-org.apache.hadoop:hadoop-common:3.3.0-SNAPSHOT
    +-org.eclipse.jetty:jetty-server:9.3.24.v20180605
      +-org.eclipse.jetty:jetty-http:9.3.24.v20180605
and
+-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
  +-org.apache.hbase:hbase-server:2.0.0-beta-1
    +-org.apache.hbase:hbase-http:2.0.0-beta-1
      +-org.eclipse.jetty:jetty-http:9.3.19.v20170502

[WARNING]
Dependency convergence error for org.eclipse.jetty:jetty-security:9.3.24.v20180605 paths to
dependency are:
+-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
  +-org.apache.hadoop:hadoop-common:3.3.0-SNAPSHOT
    +-org.eclipse.jetty:jetty-servlet:9.3.24.v20180605
      +-org.eclipse.jetty:jetty-security:9.3.24.v20180605
and
+-org.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-client:3.3.0-SNAPSHOT
  +-org.apache.hbase:hbase-server:2.0.0-beta-1
    +-org.apache.hbase:hbase-http:2.0.0-beta-1
      +-org.eclipse.jetty:jetty-security:9.3.19.v20170502

[WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence failed with message:
Failed while enforcing releasability. See above detailed error message.
{noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message