hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira Ajisaka (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-15873) JavaBeans Activation Framework API uses CDDL/GPLv2+CE license
Date Tue, 23 Oct 2018 01:31:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-15873?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16659910#comment-16659910
] 

Akira Ajisaka commented on HADOOP-15873:
----------------------------------------

The license is compatible, however, I forgot to update the NOTICE.txt in HADOOP-15775. Attached
a patch to update NOTICE.txt.

> JavaBeans Activation Framework API uses CDDL/GPLv2+CE license
> -------------------------------------------------------------
>
>                 Key: HADOOP-15873
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15873
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.3.0
>            Reporter: Wei-Chiu Chuang
>            Assignee: Akira Ajisaka
>            Priority: Blocker
>         Attachments: HADOOP-15873.01.patch
>
>
> When I compile HBase master trunk against Hadoop trunk
> {code}
> $ mvn package -Dhadoop.profile=3.0 -Dhadoop-three.version=3.3.0-SNAPSHOT -DskipTests=true
> {code}
> , it fails to compile:
> {quote}
> [INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (check-aggregate-license) @ hbase-shaded-client
---
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.EvaluateBeanshell failed with message:
> License errors detected, for more detail find ERROR in
>                     /Users/weichiu/sandbox/hbase/hbase-shaded/hbase-shaded-client/target/maven-shared-archive-resources/META-INF/LICENSE
> {quote}
> Checking the error in the file,  I saw
> {quote}
> --
> This product includes JavaBeans Activation Framework API jar licensed under the CDDL/GPLv2+CE.
> CDDL or GPL version 2 plus the Classpath Exception
> ERROR: Please check ^^^^^^^^^^^^ this License for acceptability here:
> https://www.apache.org/legal/resolved
> If it is okay, then update the list named 'non_aggregate_fine' in the LICENSE.vm file.
> If it isn't okay, then revert the change that added the dependency.
> More info on the dependency:
> <groupId>javax.activation</groupId>
> <artifactId>javax.activation-api</artifactId>
> <version>1.2.0</version>
> {quote}
> It looks like the dependency was added in HADOOP-15775. [~ajisakaa] [~tasanuma0829] could
you check? We'll need to understand the license of this library
> https://github.com/javaee/activation/blob/master/LICENSE.txt



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message