hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-15700) ABFS: Failure in OpenSSLProvider should fall back to JSSE
Date Mon, 03 Sep 2018 10:27:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-15700?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16601993#comment-16601993
] 

Steve Loughran commented on HADOOP-15700:
-----------------------------------------

Although this is going in to trunk, it's not using java 8 language features (e.g. closures;
the uses of LambdaTestUtils.intercept() are still using Callable, for example).

If anyone wants to backport this to branch-2, which is released with a java7 JDK (its in the
docker images), this patch is needed.

> ABFS: Failure in OpenSSLProvider should fall back to JSSE
> ---------------------------------------------------------
>
>                 Key: HADOOP-15700
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15700
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/azure
>            Reporter: Vishwajeet Dusane
>            Assignee: Vishwajeet Dusane
>            Priority: Major
>         Attachments: HADOOP-15700-HADOOP-15407-01.patch
>
>
> Failure to {{OpenSSLProvider.register()}} should fall back to default JSSE initialization.
This is needed to support Java 7 in case the HADOOP-15669 is back-ported to support Java7.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message