hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Yang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-15610) Hadoop Docker Image Pip Install Fails
Date Wed, 18 Jul 2018 22:12:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-15610?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16548467#comment-16548467
] 

Eric Yang commented on HADOOP-15610:
------------------------------------

[~aw] Hadoop has very little python code.  (3 files to be exact).  The delta between Pylint
1.5 and 1.9 are the following new features:

- generated-members
- redefining-builtins-modules
- unsupported-assignment-operation
- unsupported-delete-operation
- tailing-newlines
- useless-super-delegations
- used-prior-global-declaration in Python 3.6 syntax
- python 3 eq-without-hash
- lots of python 3 checks

I don't think any of the existing python code requires any of the new features.  Tailing-newlines
is probably the only feature that may be encountered during the check, if the python files
are modified in Hadoop source code.  I think this is still safer than using a pylint that
fails encoding test, and save quite a bit of time to recompile pylint with fluid dependencies
that might change between purges of docker image cache.

> Hadoop Docker Image Pip Install Fails
> -------------------------------------
>
>                 Key: HADOOP-15610
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15610
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Jack Bearden
>            Assignee: Jack Bearden
>            Priority: Critical
>              Labels: docker, trunk
>         Attachments: HADOOP-15610.001.patch, HADOOP-15610.002.patch, HADOOP-15610.003.patch,
HADOOP-15610.004.patch, HADOOP-15610.005.patch
>
>
> The Hadoop Docker image on trunk does not build. The pip package on the Ubuntu Xenial
repo is out of date and fails by throwing the following error when attempting to install
pylint:
> "You are using pip version 8.1.1, however version 10.0.1 is available"
> The following patch fixes this issue.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message