hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suma Shivaprasad (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-15502) Rolling upgrade from HADOOP 2.x to 3.x breaks due to backward in-compatible change in MetricsPlugin interface
Date Wed, 30 May 2018 03:50:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-15502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16494642#comment-16494642
] 

Suma Shivaprasad commented on HADOOP-15502:
-------------------------------------------

Thanks [~rohithsharma] for finding this issue

> Rolling upgrade from HADOOP 2.x to 3.x breaks due to backward in-compatible change in
MetricsPlugin interface
> -------------------------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-15502
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15502
>             Project: Hadoop Common
>          Issue Type: Task
>            Reporter: Suma Shivaprasad
>            Priority: Major
>
> HADOOP-13660 breaks backward compatibility due to API changes in MetricsPlugin. This
also breaks rolling upgrades since any client implementing this - like HadoopTimelineMetricsSink
in Ambari is affected - see https://issues.apache.org/jira/browse/AMBARI-20156.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message