hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "PandaMonkey (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-15261) Upgrade commons-io from 2.4 to 2.5
Date Mon, 26 Feb 2018 07:20:00 GMT
PandaMonkey created HADOOP-15261:
------------------------------------

             Summary: Upgrade commons-io from 2.4 to 2.5
                 Key: HADOOP-15261
                 URL: https://issues.apache.org/jira/browse/HADOOP-15261
             Project: Hadoop Common
          Issue Type: Bug
          Components: minikdc
    Affects Versions: 3.0.0-alpha3
            Reporter: PandaMonkey
         Attachments: hadoop.txt

Hi, after analyzing hadoop-common-project\hadoop-minikdc\pom.xml, we found that Hadoop depends
on org.apache.kerby:kerb-simplekdc 1.0.1, which transitivity introduced commons-io:2.5. 
At the same time, Spark-core directly depends on a older version of commons-io:2.4. By further
look into the source code, these two versions of commons-io have many different features.
The dependency conflict problem brings high risks of "NotClassDefFoundError:" or "NoSuchMethodError"
issues at runtime. Please notice this problem. Maybe upgrading commons-io from 2.4 to 2.5
is a good choice. Hope this report can help you. Thanks!
 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message