hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-15214) Make Hadoop compatible with Guava 21.0
Date Thu, 08 Feb 2018 18:53:02 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-15214?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16357403#comment-16357403
] 

Steve Loughran commented on HADOOP-15214:
-----------------------------------------

looks like HADOOP-14705 got the stopwatch in to KMS; easy to inadvertently do.

Is there a way for us to have findbugs block imports of specific classes? We should be able
to prevent this.

> Make Hadoop compatible with Guava 21.0
> --------------------------------------
>
>                 Key: HADOOP-15214
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15214
>             Project: Hadoop Common
>          Issue Type: Sub-task
>    Affects Versions: 3.0.0
>            Reporter: Igor Dvorzhak
>            Assignee: Igor Dvorzhak
>            Priority: Minor
>         Attachments: HADOOP-15214.001.patch
>
>
> There are only 3 changes that need to be done to make Hadoop compile with Guava 21.0
dependency



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message