hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wei-Chiu Chuang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-15054) upgrade hadoop dependency on commons-codec to 1.11
Date Wed, 29 Nov 2017 17:29:00 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-15054?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Wei-Chiu Chuang updated HADOOP-15054:
-------------------------------------
       Resolution: Fixed
    Fix Version/s: 3.1.0
           Status: Resolved  (was: Patch Available)

Thanks PJ Fanning for proposing the upgrade, and [~bharatviswa] for the patch.

Committed the patch to trunk (3.1.0).
 
I've verified that after the change, Hadoop depends on commons-codec 1.11, and I also subjected
the patch against our internal test infrastructure to verify it does not break downstream
applications (at least for CDH per se).

> upgrade hadoop dependency on commons-codec to 1.11
> --------------------------------------------------
>
>                 Key: HADOOP-15054
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15054
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0-beta1
>            Reporter: PJ Fanning
>            Assignee: Bharat Viswanadham
>             Fix For: 3.1.0
>
>         Attachments: HADOOP-15054.00.patch
>
>
> https://mvnrepository.com/artifact/org.apache.hadoop/hadoop-auth/3.0.0-beta1 retains
the dependency on an old commons-codec version (1.4).
> And hadoop-common.
> Would it be possible to consider an upgrade to 1.11?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message