hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-14981) SnappyCodec.checkNativeCodeLoaded raises UnsatisfiedLinkError if native code is missing
Date Wed, 25 Oct 2017 14:41:00 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-14981?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steve Loughran updated HADOOP-14981:
------------------------------------
    Affects Version/s: 2.8.0
          Component/s: common

> SnappyCodec.checkNativeCodeLoaded raises UnsatisfiedLinkError if native code is missing
> ---------------------------------------------------------------------------------------
>
>                 Key: HADOOP-14981
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14981
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: common
>    Affects Versions: 2.8.0
>            Reporter: Steve Loughran
>
> I'm getting a stack trace on trunk because there is no native lib on the path and Snappy
has been invoked
> {code}
>   at java.lang.Thread.run(Thread.java:745)
>   ...  Cause: java.lang.UnsatisfiedLinkError: org.apache.hadoop.util.NativeCodeLoader.buildSupportsSnappy()Z
>   at org.apache.hadoop.util.NativeCodeLoader.buildSupportsSnappy(Native Method)
>   at org.apache.hadoop.io.compress.SnappyCodec.checkNativeCodeLoaded(SnappyCodec.java:63)
> {code}
> HADOOP-13684 touched these lines in the past, 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message