hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiao Chen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13684) Snappy may complain Hadoop is built without snappy if libhadoop is not found.
Date Wed, 25 Oct 2017 17:28:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13684?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16219135#comment-16219135
] 

Xiao Chen commented on HADOOP-13684:
------------------------------------

Thanks [~stevel@apache.org].

[~jojochuang] could you provide more details?
I recall Wei-Chiu verified this internally with an escalation, where a confusing error message
was seen.
{quote}. Wei-Chiu Chuang added a comment - Aug/29/17 08:32 AM
 HADOOP-13684 did not fix a bug. It simply corrects an incorrect log message more precise.
{quote}

Looking at HADOOP-14981 and this one, one possible fix could be moving the {{isNativeCodeLoaded}}
check before {{buildSupportsSnappy}}.

> Snappy may complain Hadoop is built without snappy if libhadoop is not found.
> -----------------------------------------------------------------------------
>
>                 Key: HADOOP-13684
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13684
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Wei-Chiu Chuang
>            Assignee: Wei-Chiu Chuang
>            Priority: Minor
>              Labels: supportability
>             Fix For: 2.8.0, 3.0.0-alpha2
>
>         Attachments: HADOOP-13684.001.patch, HADOOP-13684.002.patch
>
>
> If for some reason libhadoop can not be found/loaded, Snappy complains Hadoop is not
built with Snappy but it actually is.
> {code:title=SnappyCodec.java}
> public static void checkNativeCodeLoaded() {
>       if (!NativeCodeLoader.isNativeCodeLoaded() ||
>           !NativeCodeLoader.buildSupportsSnappy()) {
>         throw new RuntimeException("native snappy library not available: " +
>             "this version of libhadoop was built without " +
>             "snappy support.");
>       }
> {code}
> This case may happen with MAPREDUCE-6577.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message