hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13363) Upgrade protobuf from 2.5.0 to something newer
Date Thu, 14 Sep 2017 21:31:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13363?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16166990#comment-16166990
] 

Andrew Wang commented on HADOOP-13363:
--------------------------------------

I consider shading a prerequisite for the PB upgrade. If we shade, there aren't any API/ABI
compatibility issues. We need wire-compatibility no matter when we upgrade, whether it's from
2.x to 3.0, or 2.x to 3.1.

Also, the motivation I've heard for upgrading is to make it easier for devs to build Hadoop
since it's hard to find a copy of PB 2.5.0. If that's the problem, there are other solutions
that do not have any downstream user impact. For instance, hosting the PB 2.5.0 binary somewhere,
or providing it in a docker image.

> Upgrade protobuf from 2.5.0 to something newer
> ----------------------------------------------
>
>                 Key: HADOOP-13363
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13363
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 3.0.0-alpha1, 3.0.0-alpha2
>            Reporter: Allen Wittenauer
>            Assignee: Tsuyoshi Ozawa
>         Attachments: HADOOP-13363.001.patch, HADOOP-13363.002.patch, HADOOP-13363.003.patch,
HADOOP-13363.004.patch, HADOOP-13363.005.patch
>
>
> Standard protobuf 2.5.0 does not work properly on many platforms.  (See, for example,
https://gist.github.com/BennettSmith/7111094 ).  In order for us to avoid crazy work arounds
in the build environment and the fact that 2.5.0 is starting to slowly disappear as a standard
install-able package for even Linux/x86, we need to either upgrade or self bundle or something
else.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message