hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun Suresh (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-12708) SSL based embeded jetty for hadoop services should allow configuration for elect cipher suites
Date Fri, 29 Sep 2017 20:51:15 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-12708?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arun Suresh updated HADOOP-12708:
---------------------------------
    Target Version/s: 3.1.0  (was: 2.9.0)

> SSL based embeded jetty for hadoop services should allow configuration for elect cipher
suites
> ----------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-12708
>                 URL: https://issues.apache.org/jira/browse/HADOOP-12708
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Vijay Singh
>
> Currently all hadoop services use emebeded jetty server. Effort to exclude cipher suite
is being tracked under Hadoop-12668. However, hadoop should allow to restrict the cipher suites
using explicit list of cipher suites. Current, pom dependency does not allow interface to
include select cipher suites. As a result, the options include following:
> 1) Upgrade jetty from 6.x to 8.x or 9.x
> 2) Contemplate and Implement WAR based implementation for these services
> 3) Include ability to select specific cipher suites



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message