hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haibo Chen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-14284) Shade Guava everywhere
Date Tue, 08 Aug 2017 23:06:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-14284?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16119162#comment-16119162
] 

Haibo Chen commented on HADOOP-14284:
-------------------------------------

Following through the discussions, folks seem to prefer shading just client jars since we
still want to use/upgrade guava in hadoop and we do not want to enforce the guava version
on downstream projects.
[~djp] Can you elaborate on why you think the shaded yarn/mr client is blocking the work here?
Cann't we do them in parallel?
To reduce build time, we could move the third-party module into an auxiliary hadoop project,
like what HBase community is doing, so that we avoid shading every time hadoop is built. Thoughts?

> Shade Guava everywhere
> ----------------------
>
>                 Key: HADOOP-14284
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14284
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 3.0.0-alpha4
>            Reporter: Andrew Wang
>            Assignee: Tsuyoshi Ozawa
>            Priority: Blocker
>         Attachments: HADOOP-14238.pre001.patch, HADOOP-14284.002.patch, HADOOP-14284.004.patch,
HADOOP-14284.007.patch, HADOOP-14284.010.patch, HADOOP-14284.012.patch
>
>
> HADOOP-10101 upgraded the guava version for 3.x to 21.
> Guava is broadly used by Java projects that consume our artifacts. Unfortunately, these
projects also consume our private artifacts like {{hadoop-hdfs}}. They also are unlikely on
the new shaded client introduced by HADOOP-11804, currently only available in 3.0.0-alpha2.
> We should shade Guava everywhere to proactively avoid breaking downstreams. This isn't
a requirement for all dependency upgrades, but it's necessary for known-bad dependencies like
Guava.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message