hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Krogen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-14502) Confusion/name conflict between NameNodeActivity#BlockReportNumOps and RpcDetailedActivity#BlockReportNumOps
Date Thu, 27 Jul 2017 22:42:00 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-14502?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Erik Krogen updated HADOOP-14502:
    Release Note: Remove the BlockReport(NumOps,AvgTime) metrics emitted under the NameNodeActivity
context in favor of StorageBlockReport(NumOps,AvgTime) which more accurately represent the
metric. Same for the corresponding quantile metrics.

> Confusion/name conflict between NameNodeActivity#BlockReportNumOps and RpcDetailedActivity#BlockReportNumOps
> ------------------------------------------------------------------------------------------------------------
>                 Key: HADOOP-14502
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14502
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: metrics
>            Reporter: Erik Krogen
>            Assignee: Erik Krogen
>            Priority: Minor
>              Labels: Incompatible
>             Fix For: 3.0.0-alpha4
>         Attachments: HADOOP-14502.000.patch, HADOOP-14502.001.patch, HADOOP-14502.002.patch
> Currently the {{BlockReport(NumOps|AvgTime)}} metrics emitted under the {{RpcDetailedActivity}}
context and those emitted under the {{NameNodeActivity}} context are actually reporting different
things despite having the same name. {{NameNodeActivity}} reports the count/time of _per storage_
block reports, whereas {{RpcDetailedActivity}} reports the count/time of _per datanode_ block
reports. This makes for a confusing experience with two metrics having the same name reporting
different values. 
> We already have the {{StorageBlockReportsOps}} metric under {{NameNodeActivity}}. Can
we make {{StorageBlockReport}} a {{MutableRate}} metric and remove {{NameNodeActivity#BlockReport}}
metric? Open to other suggestions about how to address this as well. The 3.0 release seems
a good time to make this incompatible change.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message