hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-14614) Hive doesn't let s3a patch the credential provider path
Date Thu, 29 Jun 2017 19:48:00 GMT
Steve Loughran created HADOOP-14614:
---------------------------------------

             Summary: Hive doesn't let s3a patch the credential provider path
                 Key: HADOOP-14614
                 URL: https://issues.apache.org/jira/browse/HADOOP-14614
             Project: Hadoop Common
          Issue Type: Sub-task
          Components: fs/s3
    Affects Versions: 2.8.1
            Reporter: Steve Loughran


Hive doesn't let us patch the {{hadoop.security.credential.provider.path}} option, so the
dynamic per-bucket fixup of credentials fails.

{code}
Error: Failed to open new session: org.apache.hive.service.cli.HiveSQLException: java.lang.IllegalArgumentException:
Cannot modify hadoop.security.credential.provider.path at runtime. It is not in list of params
that are allowed to be modified at runtime (state=,code=0)
{code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message