hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-14595) SwiftNativeFileSystem Internal method has not been used
Date Tue, 27 Jun 2017 10:29:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-14595?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16064617#comment-16064617
] 

Steve Loughran commented on HADOOP-14595:
-----------------------------------------

All patches against object stores, no matter how trivial, have to be accompanied by a declaration
that you ran that modules test suite, and naming the service you tested against.

sorry, but we've been burned so, many, many times, even by myself.

https://wiki.apache.org/hadoop/HowToContribute#Submitting_patches_against_object_stores_such_as_Amazon_S3.2C_OpenStack_Swift_and_Microsoft_Azure

> SwiftNativeFileSystem Internal method has not been used
> -------------------------------------------------------
>
>                 Key: HADOOP-14595
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14595
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs/swift
>    Affects Versions: 2.8.1
>            Reporter: Yasen Liu
>            Priority: Trivial
>         Attachments: HADOOP-14595.001.patch
>
>
> i found the method is unused  method,and is internal implementation.In order to keep
the code clean,I think it should be deleted or marked as unused.
> /**
>    * internal implementation of directory creation.
>    *
>    * @param path path to file
>    * @return boolean file is created; false: no need to create
>    * @throws IOException if specified path is file instead of directory
>    */
>   private boolean mkdir(Path path) throws IOException {
>     Path directory = makeAbsolute(path);
>     boolean shouldCreate = shouldCreate(directory);
>     if (shouldCreate) {
>       forceMkdir(directory);
>     }
>     return shouldCreate;
>   }



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message