hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhe Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HADOOP-14502) Confusion/name conflict between NameNodeActivity#BlockReportNumOps and RpcDetailedActivity#BlockReportNumOps
Date Wed, 07 Jun 2017 18:32:18 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-14502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16041381#comment-16041381
] 

Zhe Zhang edited comment on HADOOP-14502 at 6/7/17 6:32 PM:
------------------------------------------------------------

bq. Can we make StorageBlockReport a MutableRate metric and remove NameNodeActivity#BlockReport
metric
This sounds good to me (as a 3.0 change).

Pinging [~andrew.wang] for opinion on breaking compatibility in this case.


was (Author: zhz):
bq. Can we make StorageBlockReport a MutableRate metric and remove NameNodeActivity#BlockReport
metric
This sounds good to me (as a 3.0 change).

> Confusion/name conflict between NameNodeActivity#BlockReportNumOps and RpcDetailedActivity#BlockReportNumOps
> ------------------------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-14502
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14502
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: metrics
>            Reporter: Erik Krogen
>            Priority: Minor
>
> Currently the {{BlockReport(NumOps|AvgTime)}} metrics emitted under the {{RpcDetailedActivity}}
context and those emitted under the {{NameNodeActivity}} context are actually reporting different
things despite having the same name. {{NameNodeActivity}} reports the count/time of _per storage_
block reports, whereas {{RpcDetailedActivity}} reports the count/time of _per datanode_ block
reports. This makes for a confusing experience with two metrics having the same name reporting
different values. 
> We already have the {{StorageBlockReportsOps}} metric under {{NameNodeActivity}}. Can
we make {{StorageBlockReport}} a {{MutableRate}} metric and remove {{NameNodeActivity#BlockReport}}
metric? Open to other suggestions about how to address this as well. The 3.0 release seems
a good time to make this incompatible change.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message