hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Douglas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11875) [JDK9] Renaming _ as a one-character identifier to another identifier
Date Tue, 27 Jun 2017 19:51:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11875?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16065370#comment-16065370
] 

Chris Douglas commented on HADOOP-11875:
----------------------------------------

To be clear, this is adding a second copy of Hamlet's generated code in a different package?
[~ajisakaa], _thank you_ for taking this on. There are no good choices here. At least to unblock
this, I'm +1 on the patch. There might be a way to have the {{\_}} interface extend {{\_\_}}
and/or provide a default implementation that's compatible, but it's probably not worth it.

[~stevel@apache.org], I don't want to break users either, but our compatibility guidelines
don't require us to maintain Hamlet indefinitely. The original intent was to move it out of
YARN to find a community that can support it. If the YARN server UIs are rewritten, it may
make sense to move it out of yarn-common and into mapreduce (which is unlikely to have its
UI rewritten). Hamlet can be a separate dependency, but applications would need to update
or deployments would need to add it. Would that suffice?

> [JDK9] Renaming _ as a one-character identifier to another identifier
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-11875
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11875
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Tsuyoshi Ozawa
>            Assignee: Akira Ajisaka
>              Labels: webapp
>         Attachments: build_error_dump.txt, HADOOP-11875.01.patch, HADOOP-11875.02.patch,
HADOOP-11875.03.patch, HADOOP-11875.04.patch, HADOOP-11875.05.patch, HADOOP-11875.06.patch,
HADOOP-11875.07.patch
>
>
> From JDK9, _ as a one-character identifier is banned. Currently Web UI uses it. We should
fix them to compile with JDK9. https://bugs.openjdk.java.net/browse/JDK-8061549



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message