hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vrushali C (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HADOOP-10101) Update guava dependency to the latest version
Date Mon, 08 May 2017 18:00:06 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-10101?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16001207#comment-16001207
] 

Vrushali C edited comment on HADOOP-10101 at 5/8/17 5:59 PM:
-------------------------------------------------------------

bq. Has anyone contacted the maintainers on the major affected downstream projects like Spark
and HBase? My guess is that they would be more than happy to help work around any breakages
this upgrade causes – if they are like us, they would be overjoyed at being able to finally
upgrade.

There is an open jira in HBase to upgrade to guava 21 HBASE-17908 and I just noticed that
Stack mentioned they are looking to shade out guava in a prebuild step.

HBASE-13517 provided shaded client and server jars. But these shaded jars can't be used inside
of coprocessors (which timeline service in yarn currently makes use of). 

For Spark it does look like their users have run into issues as noted in SPARK-16725 and they
are hoping hadoop 3.x will upgrade guava. 


was (Author: vrushalic):
bq. Has anyone contacted the maintainers on the major affected downstream projects like Spark
and HBase? My guess is that they would be more than happy to help work around any breakages
this upgrade causes – if they are like us, they would be overjoyed at being able to finally
upgrade.

There is an open jira in HBase to upgrade to guava 21 but I don't see a lot of activity on
it HBASE-17908. 
HBASE-13517 provided shaded client and server jars. But these shaded jars can't be used inside
of coprocessors (which timeline service in yarn currently makes use of). 

For Spark it does look like their users have run into issues as noted in SPARK-16725 and they
are hoping hadoop 3.x will upgrade guava. 

> Update guava dependency to the latest version
> ---------------------------------------------
>
>                 Key: HADOOP-10101
>                 URL: https://issues.apache.org/jira/browse/HADOOP-10101
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Rakesh R
>            Assignee: Tsuyoshi Ozawa
>              Labels: BB2015-05-TBR
>             Fix For: 3.0.0-alpha3
>
>         Attachments: HADOOP-10101-002.patch, HADOOP-10101-004.patch, HADOOP-10101-005.patch,
HADOOP-10101-006.patch, HADOOP-10101-007.patch, HADOOP-10101-008.patch, HADOOP-10101-009.patch,
HADOOP-10101-009.patch, HADOOP-10101-010.patch, HADOOP-10101-010.patch, HADOOP-10101-011.patch,
HADOOP-10101.012.patch, HADOOP-10101.013.patch, HADOOP-10101.014.patch, HADOOP-10101.015.patch,
HADOOP-10101.016.patch, HADOOP-10101.017.patch, HADOOP-10101.018.patch, HADOOP-10101.patch,
HADOOP-10101.patch
>
>
> The existing guava version is 11.0.2 which is quite old. This issue tries to update the
version to as latest version as possible. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message