hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-14276) Add a nanosecond API to Time/Timer/FakeTimer
Date Mon, 17 Apr 2017 15:42:43 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-14276?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15971194#comment-15971194

Hudson commented on HADOOP-14276:

SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11591 (See [https://builds.apache.org/job/Hadoop-trunk-Commit/11591/])
HADOOP-14276. Add a nanosecond API to Time/Timer/FakeTimer. Contributed (zhz: rev 95b7f1d29a5e2dadd70a56fca5faa006c5bd74fc)
* (edit) hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Timer.java
* (edit) hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Time.java
* (edit) hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestLightWeightCache.java
* (edit) hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/LightWeightCache.java
* (edit) hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/FakeTimer.java

> Add a nanosecond API to Time/Timer/FakeTimer
> --------------------------------------------
>                 Key: HADOOP-14276
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14276
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>            Reporter: Erik Krogen
>            Assignee: Erik Krogen
>            Priority: Minor
>             Fix For: 2.9.0, 2.7.4, 2.8.1, 3.0.0-alpha3
>         Attachments: HADOOP-14276.000.patch
> Right now {{Time}}/{{Timer}} export functionality for retrieving time at a millisecond-level
precision but not at a nanosecond-level precision, which is required for some applications
(there's ~70 usages). Most of these seem not to need mocking functionality for tests; only
one class currently mocks this out ({{LightWeightCache}}) but we would like to add another
as part of HDFS-11615 and want to avoid code duplication. This could be useful for other classes
in the future as well.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message