hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Zeng (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HADOOP-14261) Some refactoring work for erasure coding raw coder
Date Fri, 21 Apr 2017 09:52:04 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-14261?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15978410#comment-15978410
] 

Lin Zeng edited comment on HADOOP-14261 at 4/21/17 9:51 AM:
------------------------------------------------------------

# Refactoring work:
#* Rename RSRawDecoderLegacy to RSLegacyRawDecoder.
#* Rename RSRawEncoderLegacy to RSLegacyRawEncoder.
#* Rename RSRawErasureCoderFactoryLegacy to RSLegacyRawErasureCoderFactory.
#* Rename TestRSRawCoderLegacy to TestRSLegacyRawCoder.
# Create RawEncoder and RawDecoder via the appropriate factory.


was (Author: zenglinx):
# Refactor work:
#* Rename RSRawDecoderLegacy to RSLegacyRawDecoder.
#* Rename RSRawEncoderLegacy to RSLegacyRawEncoder.
#* Rename RSRawErasureCoderFactoryLegacy to RSLegacyRawErasureCoderFactory.
#* Rename TestRSRawCoderLegacy to TestRSLegacyRawCoder.
# Create RawEncoder and RawDecoder via the appropriate factory.

> Some refactoring work for erasure coding raw coder
> --------------------------------------------------
>
>                 Key: HADOOP-14261
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14261
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Kai Zheng
>            Assignee: Lin Zeng
>             Fix For: 3.0.0-alpha3
>
>         Attachments: HADOOP-14261.001.patch
>
>
> This is from [~andrew.wang] commented in HADOOP-13200:
> {quote}
> Other questions/comments from looking at this code:
> We also should rename RSRawEncoderLegacy to RSLegacyRawEncoder and RSRawErasureCoderFactoryLegacy
to RSLegacyErasureCoderFactory, to match the naming of other subclasses.
> TestRawEncoderBase, should this use a configured factory to get the raw coders, rather
than referencing the raw coders directly? I didn't check other usages, but it seems like we
should be creating via the appropriate factory whenever possible.
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message