hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Fabbri (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-14129) ITestS3ACredentialsInURL sometimes fails
Date Fri, 03 Mar 2017 23:05:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-14129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15895214#comment-15895214
] 

Aaron Fabbri commented on HADOOP-14129:
---------------------------------------

[~liuml07] yes, v5 LGTM.  +1

> ITestS3ACredentialsInURL sometimes fails
> ----------------------------------------
>
>                 Key: HADOOP-14129
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14129
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/s3
>    Affects Versions: HADOOP-13345
>            Reporter: Sean Mackrory
>            Assignee: Sean Mackrory
>             Fix For: HADOOP-13345
>
>         Attachments: HADOOP-14129-HADOOP-13345.001.patch, HADOOP-14129-HADOOP-13345.002.patch,
HADOOP-14129-HADOOP-13345.003.patch, HADOOP-14129-HADOOP-13345.004.patch, HADOOP-14129-HADOOP-13345.005.patch
>
>
> This test sometimes fails. I believe it's expected that DynamoDB doesn't have access
to the credentials if they're embedded in the URL instead of the configuration (and IMO that's
fine - since the functionality hasn't been in previous releases and since we want to discourage
this practice especially now that there are better alternatives). Weirdly, I only sometimes
get this failure on the HADOOP-13345 branch. But if the problem turns out to be what I think
it is, a simple Assume should fix it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message