hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13715) Add isErasureCoded() API to FileStatus class
Date Thu, 23 Mar 2017 23:44:41 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13715?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15939451#comment-15939451
] 

Andrew Wang commented on HADOOP-13715:
--------------------------------------

Cool, glad that we found this via unit test :) Took a deeper look, just one last comment,
my bad for not mentioning this earlier:

* Could we rename the JSON field "erasureBit" to "ecBit" for conciseness? This will make the
wire representation a little more compact. Also rename {{ERASURE_CODED_BIT_JSON}} to {{EC_BIT_JSON}}
to match as well.

> Add isErasureCoded() API to FileStatus class
> --------------------------------------------
>
>                 Key: HADOOP-13715
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13715
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Wei-Chiu Chuang
>            Assignee: Manoj Govindassamy
>            Priority: Blocker
>              Labels: hdfs-ec-3.0-must-do
>         Attachments: HADOOP-13715.01.patch, HADOOP-13715.02.patch, HADOOP-13715.03.patch,
HADOOP-13715.04.patch, HADOOP-13715.05.patch
>
>
> Per the discussion in [HDFS-10971|https://issues.apache.org/jira/browse/HDFS-10971?focusedCommentId=15567108&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15567108]
I would like to add a new API {{isErasureCoded()}} to {{FileStatus}} so that tools and downstream
applications can tell if it needs to treat a file differently.
> Hadoop tools that can benefit from this effort include: distcp and teragen/terasort.
> Downstream applications such as flume or hbase may also benefit from it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message